
Visualization and processing of weather radar data

1 Learning Objectives

The following are the learning objectives for this assignment:

• Learn how to request and retrieve NEXRAD data from the NCDC data server

• Use the NCDC Java NEXRAD Viewer to display NEXRAD data

• Familiarize yourself with the WeatherScope GUI and how to plot multiple fields on one map.

• Explore the utility of incorporating alternate data sources into your weather radar analysis

2 Introduction

Data from the network of WSR-88D weather surveillance radars (NEXRAD) operated by NOAA
are available from the National Climate Data Center (NCDC). These data are provided in Level
II and Level III formats. Basically, Level II data contain the radar moments (reflectivity, radial ve-
locity, and spectrum width) contained on a coordinate grid consistent with the particular volume
coverage pattern (VCP) used for data collection. Level III data are processed products, which
can be displayed as images. For more information see:
http://www.ncdc.noaa.gov/oa/radar/radarresources.html.
The data are stored in a NEXRAD Information Dissemination Service (NIDS) format. Visualiza-
tion software are available and two of these are described below.

2.1 WeatherScope

The WeatherScope program, written and distributed by the Oklahoma Climatological Survey
(http://climate.ok.gov/software) provides a user-friendly, cross-platform framework for the
visualization of meteorological data. It is also highly customizable, allowing users to generate
datasets for their own needs for use inside of the program.

Installing WeatherScope
Inside a web browser, visit the address listed above and you will see two software packages avail-
able for download. The WxScope Plugin allows you to view animations of Oklahoma Mesonet
data inside your browser window, but is not necessary for the operation of WeatherScope itself.
Select the platform on which you desire to install the program, and the download will begin im-
mediately (.dmg file for Macintosh, .exe file for Windows). Note: WeatherScope is not currently
available for UNIX/Linux distributions. If you do not have access to either a Mac or a Windows
PC, the student computer lab on the 5th floor has WeatherScope installed already.
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Figure 1: General layout of the WeatherScope GUI.

Once your download concludes, begin the installation process by double-clicking the icon on
your Desktop. It will take less than 5 minutes to complete.

The WeatherScope GUI
When you first open WeatherScope, you will see a map of Oklahoma with the county borders

illustrated (See Figure 1). There are two main portions of the GUI (See Figure 2):

• The legend pane on the left lists the products currently being displayed, the time for which
the products are valid, and the archiving and playback controls. The legend pane may be
hidden if you desire by selecting Map>Hide Legend from the menu bar.

• The right hand portion of the GUI is the data window, displaying meteorological fields of
your choice.

You may zoom in on the data window by left-clicking (clicking on Mac) over a point of interest,
and zoom out by right-clicking (option-clicking on Mac).

Viewing Products in the Data Window
Once you have familiarized yourself with the WeatherScope GUI, you should experiment with

various datasets that are available for viewing inside the data window. Start off by plotting the
current surface temperature from the Oklahoma Mesonet:

1. Choose Product>New Observation from the menu bar. An “Observation Properties” dialog
box will pop up in the center of the screen.
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Figure 2: Plotting Oklahoma Mesonet surface temperature.

Figure 3: Changing the data presentation from “Observation” to “Contour”.

2. A pulldown menu at the top of the window allows you to select the data source. It will
default to “Oklahoma Mesonet”, but observations from the ASOS network and the ARM
project are also available.

3. From the “Variable” pulldown menu, select “Air Temperature at 1.5 meters”, and your de-
sired units from the “Units” bar. You may also change the color you want the data to be
displayed in, as well as the number of decimal places from the “Precision” menu. Click the
OK button, and the data will be displayed in the data window.

Double-clicking on an item in the legend pane will bring up the “Observation Properties” dialog
box again, and you may change the field that is plotted, the color of the field, or select a different
data source. You can change the way data is presented by right-clicking (option-clicking on Mac)
an item on the legend pane and choosing “View as Contour” (to see an objective analysis of
that particular field) or “View as Gradient” (to see the field color-shaded). See Figures 3 and 4.
When using the ”View as Gradient” option, it is generally a good idea to decrease the ”Opacity”
slider in the ”Observation Properties” dialog box so the gradient does not obscure other plotted
values. You can try this for yourself by selecting Product>New Observation from the menu bar,
and selecting a different field to plot. Then change it to a gradient or contour to see how the two
interact. Multiple fields behave like layers, in that you can move them around in the legend pane
to change the order in which they are plotted. Fields near the top will be plotted above those
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Figure 4: Changing the data presentation from “Contour” to “Gradient”. Note the county outline
layer is above the gradient in the Legend pane.

near the bottom. If you choose to plot gradients, they should be near the bottom or have a lower
opacity value so they do not obscure other fields you have plotted.

In addition to scalar fields (temperature, pressure, humidity, etc.), you may also plot wind vectors
or barbs (Product>New Vector), radar data (Product>New Radar), or various geographic features
such as state lines or major interstates (Product>New Shape).

Data Inspector
WeatherScope comes with a built-in explorer that allows you to closely examine plotted data,
aptly named the Inspector. To use the Inspector, select Window>Show Inspector, or right-click
(option-click on Mac) on a field of your choice in the legend pane, select ”Show Inspector” and
a small dialog box will open. See Figure 5. For observation data, the Inspector will give you
information about the nearest station, and for gradient or contour fields the Inspector will track
the value represented by the location of your mouse pointer as you move it across the map.
The Inspector is especially useful when examining radar data, as it will allow you to view storm
attributes when the Composite Reflectivity field is plotted.

Producing Animations
For most applications, it is useful to be able to animate the data you plot so you may track the
evolution of interesting features. This is accomplished by selecting Map>Date and adjusting the
date and time at which you wish to start or end the animation, and how far before or after that
time you wish to view. You can also select the time interval between frames. Note: some data
may not always be available, due to instrument errors or network outages. Oklahoma Mesonet
data are available back to 1994, but data availability from other sources varies. Historical events,
such as the 3 May 1999 tornado outbreak, are archived permanently due to their significance.

The animation should begin automatically after you adjust the settings in the ”Date” dialog box,
but if not select Map>Play to start it. You may also move through frame-by-frame with PgUp and
PgDn.

Saving Your Work
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Figure 5: Using the Data Inspector to view storm attributes.

If you have generated a plot of various fields of interest, you can save the configuration so that
you may load it up later and continue working. The file extension .wxscript is automatically as-
sociated with WeatherScope, so you may create a map on one computer, save the configuration,
and view it on another computer. Selecting File>Save As from the menu will allow you to save
your configuration and load it later. Re-opening the .wxscript file will bring back the same fields
valid at the same time you were viewing when you closed the program. This also allows you to
create maps of particular sets of variables and view them at your leisure.

Exporting Images
If you have located a particularly interesting meteorological feature, you may export an image
of it directly from WeatherScope in .png format. To accomplish this, select File>Quick Export

from the menu. The file will be saved to your desktop with the valid time in YYYYMMDDHHmm
format as the name.

How Does WeatherScope Know Where Data Are Located?
You probably noticed the large variety of datasets available for use in WeatherScope, but how
does the program locate the data you ask for? The answer is contained in a series of XML files
that are stored both on your local computer and on the OCS server. By default, WeatherScope
generates a folder called Weather/WeatherScope Data in the My Documents folder (your home
directory /∼ on Mac) to hold configuration files and data you have saved locally.

Browse into the WeatherScope Data directory and you will see a series of sub-directories with
names such as edu.ou.mesonet.standard, which represent the datasets that are available for
visualizaton (in this case, edu.ou.mesonet.standard represents the core Oklahoma Mesonet
parameters, as well as the locations of all the sites). The edu.ou.mesonet.standard directory
contains two subdirectories - data and info. As you would expect, data contains data you have
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stored locally for later viewing. The info directory contains a group of XML files that specify the
data format, its location, how often it is updated, and other important parameters. Take some
time to familiarize yourself with the contents of these files.

The data directory is organized the same regardless of variable, typically
/data/YYYY/MM/DD/productname.
For example, the directory structure for the edu.ou.mesonet.standard directory is:
/data/YYYY/MM/DD/mdf/

as the mdf file type represents a set of observations from each Mesonet site at a single time.
Some variables have even lower-level directories, such as the Level III radar data held in
edu.ou.ocs.nids, for which the directory structure is
/data/YYYY/MM/DD/siteid/nidsid.
So, if you had some Velocity data from the 3 May 1999 tornado event saved on your computer, it
would appear in
/data/1999/05/03/KTLX/BVEL1.

2.2 Obtaining NEXRAD Data From NCDC

Ordering and Preparing NCDC Data for WeatherScope
WeatherScope requires that radar data be formatted according to the NIDS (NEXRAD Infor-
mation Dissemination Service) specification and named in a particular way to match the query
syntax (check /edu.ou.ocs.nids/info/config.xml if you’re curious). However, using a few
quick steps it is possible to convert the data so it is compatible with WeatherScope. Note: the
converter files are intended for use on a UNIX/Linux system or a Mac as they require bash and
perl capability. It may be a good idea to complete this portion of the task either in the student
computer lounge or the computer classroom if your personal machine is of the Windows variety.

1. Open your web browser and visit http://www.ncdc.noaa.gov/nexradinv/, and click on
the “Mass Storage (HAS)” option near the top of the page (See Figure 6).

2. You will be taken to the HDSS Access System, and presented with several options. For
now, we will work with Level III radar data, so select “NEXRAD Level III” from the menu,
listed under “Radar” (See Figure 7).

3. A data selection menu appears, from which you are able to select from any NEXRAD site
in North America (See Figure 8). Next to each site identifier is the dates of data availability.
Highlight the station of your choice on the left, and select the dates you would like data for
on the right side. Note: days begin at 0000 UTC, not local time. Enter your e-mail address
in the text bar below the station selection menu, and press “Continue With Selections” to
continue the download process.

4. You are presented with a set of data files spanning the time interval you selected on the
previous menu (See Figure 9). You may choose to download all the data (the top option),
or select a portion of the dataset to download (bottom option). When you have made your
selection, press the “Retrieve Selected Files” button on the right side of the menu.
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5. Your request will begin processing immediately, and you can check the progress with the
link provided in your browser window (See Figure 10). You will also recieve an e-mail when
your data are ready for download.

6. While you await the completion of your data request, you will need to grab the code to
process the compressed file. Point your web browser to http://www.ou.edu/radar/ and
download ncdc to nids.zip (See Figure 11).
Check the Readme.txt file as it details a small change you must make to the code.

7. When your NCDC data is ready, download the tar.Z file(s) to the same location as the
converter files. This is important as it will only search the directory where the converter
files are saved for archived data.

8. Open a Terminal window, browse to the location of your data and converter files, and issue
the command ./proc ncdc data.sh. Note: you may have to change the permissions on
the converter files using the chmod command.

9. The script will run through all your data and process it into the correct format and directory
structure for use in both WeatherScope and the NCDC Java NEXRAD Viewer. For an
entire day’s worth of data, the processing takes about 5 minutes. When it is complete, you
will have a new directory in the same /YYYY/MM/DD/siteid/nidsid format as you saw in
the /WeatherScope Data/edu.ou.ocs.nids/data folder. If the computer you are using has
WeatherScope installed, move the highest-level directory (YYYY) into the /WeatherScope

Data/

edu.ou.ocs.nids/data folder. Otherwise, save the contents of this folder to a Flash drive
or other means so you can access the data on a computer with WeatherScope.

10. Start up WeatherScope, choose Product>New Radar from the menu, “NEXRAD Level III”
from the dialog box, the site of the data you downloaded and a product of your choice.

11. Choose Map>Date from the menu bar, and change the date to coincide with the data you
downloaded. You should be able to overlay fields of your choice, and animate the data.

2.3 NCDC Java NEXRAD Viewer

Using the NCDC Java NEXRAD Viewer
In addition to the WeatherScope program, the NCDC also produces a visualization tool called
the Java NEXRAD Viewer (JNV) that is a cross-platform tool for viewing Level II and Level III
radar data. Unlike WeatherScope, however, JNV only displays radar data and not surface and
upper air fields. It does posess the added capability of a data dump to several popular formats,
so that the data may be further manipulated in a separate software package such as MATLAB.
A later assignment will explore this capability in greater detail.

1. If you have not already processed your data using the scripts described above, refer to
steps 1-9 above to prepare your data for viewing.
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Figure 6: NCDC NEXRAD Inventory homepage.

2. To access the JNV, point your browser to http://www.ncdc.noaa.gov/oa/radar/jnx/, and
click on the “Install Now” option near the bottom of the screen (Figure 12). Since JNV is
written in Java, it is compatible with any computer regardless of OS (including UNIX/Linux)
as long as Java is installed.

3. If you are not sure if you have Java installed on your computer, there is a link at the top of the
JNV installation page that will test your machine (Figure 13). If Java is not installed, you
may install the latest version by visiting http://java.sun.com/products/javawebstart/

and following the instructions therein.

4. Begin the program by clicking on “Launch the STABLE Version 1.6.0 Java NEXRAD Viewer
(includes Data Exporter)”, and you will begin download of the Java file. You may also run
the program without having to visit the NCDC site by saving the file to your Desktop, after
which you need only to double-click the icon to start JNV.

5. JNV will unpack itself, and you will be presented with a blank map of the United States
(the “data window”) showing major highways and state outlines and a dialog box titled
“NEXRAD Data Selector” (Figure 14).

6. You may access NCDC data either through your HAS order number (check the confirmation
e-mail you recieved), or by browsing to a local directory that contains your processed data.
If you ran the scripts as described in the WeatherScope portion of this document, you will
already have a processed dataset ready for viewing.

7. Access locally-stored data by clicking on the “Local” tab, and pressing the “Browse Local”
button on the top left-hand corner of the dialog box. A new dialog box will open where you
may browse to the location that holds the data you would like to view. The processing script
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Figure 7: Entering the Level III archives.

Figure 8: Choosing your site and dates.

has automatically separated each product into its own directory based on NIDS product
code, so 0.5 degree Base Reflectivity data would be stored in the BREF1 directory, for
example. By default, the script sets the directory structure for your data to YYYY-MM-
DD/siteid/product

8. Select the directory containing the data you wish to view and press “Open”. You will be
presented with a list of data files in the dialog box, corresponding to your desired product
from each radar volume. Choose one and select “Load”. JNV will process the data and
display it for you in the data window.

9. Exploring the map is done primarily through the use of the buttons on the top of the data
window. You may zoom in on a point of interest

10. You may animate multiple frames of radar data by selecting Tools>NEXRAD Animator from
the menu bar. You will be presented with another dialog box allowing you to select the range
of times you wish to animate. Once you have made your choice, you will be presented with
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Figure 9: Listing of available data files.

Figure 10: Confirmation of a successful data request.

the option to export the data in KMZ (Google Earth), single image, or movie format in addition
to generating an animation inside the window. Note: a large range of data will take a long
time to process, and may cause your computer to halt. Proceed with caution.
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Figure 11: Compressed directory with files needed to make NCDC Level III radar data compatible
with WeatherScope.

Figure 12: Java NEXRAD Viewer overview.
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Figure 13: Checking your machine for Java and installing the Java NEXRAD Viewer.

Figure 14: Java NEXRAD Viewer opening screen and data selection dialog box.
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3 Hands-On Activities

During May 30, 2001, a squall line developed and passed through Oklahoma, which resulted
in heavy rain across the Oklahoma City metro area and later produced two tornadoes in the
southeast corner of Oklahomaha. For more information see
http://w1.spc.woc.noaa.gov/exper/archive/events/searchindex.html.
Although the squall line was not particularly intense, it does demonstrate many of the classic
features of such a system, which were well captured through the KTLX radar images and the
surface observations from the Oklahoma Mesonet.

We will look at this system in more detail using WeatherScope and the NCDC Java Data Viewer.
To that end, you should complete the following tasks.

1. Request and retrieve Level III NEXRAD data for KTLX from the NCDC data archive for May
30, 2001

2. Run the proc_ncdc_data.sh script in preparation for viewing the data.

3. Start by viewing the data in NCDC Java NEXRAD Viewer (JNV). As discussed above, the
JNV offers many data overlay options. To explore some of these, you should:

• Launch the viewer and load the base reflectivity data (lowest elevation scan) for the
time 05:31 UT.

• Use the Overlay Selector to display state borders, interstates, and states within the
image.

• Use the Overlay Selector to select “Geog. Network Streets” as the background

• Use the Overlay Selector to set the NEXRAD transparency to 50%.

4. Save the plot as a PNG file.

5. Next display the data using WeatherScope. For the time 24:30 CDT (05:31 UT) create a
plot with the zoom set such that all or most of Oklahoma is visible.

• Show the Oklahoma county borders.

• Show the wind data at 10 m above the surface from the Mesonet (m/s) as wind vectors.
Use the gridded option when showing these vectors.

• Show the KTLX Base Reflectivity 1 data with the opacity set at 100%.

• Air temperature from the Mesonet at 1.5 m as a gradient with an opacity of 50%.

For this particular image, it is recommended that data feeds be listed in the order shown
above. The last listed is the lowest layer in the display.

6. Save the plot as a PNG file.
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7. For the time interval May 30, 24:00 to May 31, 24:00 (Note that WeatherScope uses 24:00
for midnight) use WeatherScope to create a graph showing time histories of several data
streams for Norman, OK

• Show the rainfall since midnight (mm).

• Show the air temperature (C).

• Show the dewpoint temperature (C).

Note that you will need to select the Norman (retired) site.

8. Save the plot as a PNG file.

9. Finally, produce another WeatherScope map image of your design including whatever data
that you choose, but which should be useful in analyzing the general features of the storm.

Next, we will use WeatherScope to explore the May 3, 1999 tornado outbreak. The following
web pages will provide some background information.
http://www.srh.noaa.gov/oun/storms/19990503/index.html

http://www.nssl.noaa.gov/headlines/dszpics.html

http://en.wikipedia.org/wiki/Oklahoma_Tornado_Outbreak

The KTLX radar data for this event are not available from the NCDC site (at least not at the time
while this module was being written). However, OCS maintains an archive of NEXRAD data for
several meteorological event of interest. May 3, 1999 falls within that category. So, although you
do not have these data locally stored on your computer, you can retrieve them directly from the
OCS computer.

1. Create a map display using WeatherScope. For the time 19:10 CDT (May 3, 1999) create
a plot centered on Clevland County and with the zoom set such that about 20 counties are
visible.

• Show the Oklahoma county borders.

• Show the wind data at 10 m above the surface from the Mesonet (m/s) as wind vectors.
Use the gridded option when showing these vectors.

• Show the KTLX Base Reflectivity 1 data with the opacity set at 100%.

• Air temperature from the Mesonet at 1.5 m as a gradient with an opacity of 50%.

For this particular image, it is recommended that data feeds be listed in the order shown
above. The last listed is the lowest layer in the display.

2. Save the plot as a PNG file.

3. Create another map display using WeatherScope for the same time and with the same
zoom.
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• Show the Oklahoma county borders.

• Show the wind data at 10 m above the surface from the Mesonet (m/s) as wind vectors.
Use the gridded option when showing these vectors.

• Show the KTLX Composite Reflectivity with the Display Storm Attributes box checked.

• Note that the resolution is coarser for the composite image.

• Note the locations of the mesocyclones (meso) and the tornadic vortex signatures
(TVS)

4. Save the plot as a PNG file.

5. Create another map display using WeatherScope for the same time and with the same
zoom.

• Show the Oklahoma county borders.

• Show the wind data at 10 m above the surface from the Mesonet (m/s) as wind vectors.
Use the gridded option when showing these vectors.

• Show the KTLX Base Velocity 1.

• Velocity couplets are regions associated with rotation and are indicated by abrupt
changes in the radial velocity. Note the locations of the velocity couplets in the plot in
connection with the mesocyclones and the tornadic vortex signatures.

6. Save the plot as a PNG file.

Provide a short write up in which you explain what you have done and which summarizes your
results. In the write up include the plots that you have created. Remember that the write up is
meant to be seen as a stand alone document. You are not meant to explain how WeatherScope
or the JNV are installed or provide detailed instructions as to how it is used. But, you should
mention which software package was used to produce which images and briefly discuss the
differences (strengths and weaknesses) between them. You should also say something about
the meteorological conditions present during the times of the weather events.
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